Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 11, 2026 - 05:30 UTC
Scheduled
During this window we will be upgrading our infrastructure to improve the long-term reliability of the platform. All services will be unavailable for the duration of the maintenance window. We will provide updates as necessary.
Posted May 04, 2026 - 12:35 UTC
This scheduled maintenance affected: API, Club portal, Booking portal, Partner portal, Mobile app – iOS, Mobile app – Android, Insights, and Accounting.